Printing Labels from
SAP System Using SAPscript

User Manual

Edition 01
October 2020




Copyrights

Any unauthorized reproduction of the contents of this document, in part or whole, is strictly prohibited.
© 2020 SATO Corporation. All rights reserved.

Limitation of Liability

SATO Corporation and its subsidiaries in Japan, the U.S and other countries make no representations
or warranties of any kind regarding this material, including, but not limited to, implied warranties of
merchantability and fitness for a particular purpose. SATO Corporation shall not be held responsible
for errors contained herein or any omissions from this material or for any damages, whether direct,
indirect, incidental or consequential, in connection with the furnishing, distribution, performance or use
of this material.

Specifications and contents of this document are subject to change without notice.

Trademarks

SATO is a registered trademark of SATO Holdings Corporation and its subsidiaries in Japan, the U.S.
and other countries.

SAP® and ABAP® are the trademarks or registered trademarks of SAP SE or its affiliates in Germany
and in several other countries.

NiceLabel®is a registered trademark of Euro Plus d.o.o in the U.S.A. and other countries.
BarTender® is a registered trademark of Seagull Scientific, Inc.

All other trademarks are the property of their respective owners.

Software Updating Disclaimer

While all efforts have been taken to ensure accuracy and currency of the information contained herein,
there are instances where the contents of this document may be outdated. In that case, proceed to
your local SATO regional website (https://www.sato-global.com/drivers/redirect.html) to check whether
an updated document has been made available for your reference.

Contact Information

Access the following site and select the region/country nearest to you.
https://www.sato-global.com/about/locations.html



https://www.sato-global.com/drivers/redirect.html
https://www.sato-global.com/about/locations.html

Table of Contents

Table of CONtENtS ......cceiciiiiiirr e ————————————————— 3
T O 4 Y T 4
2. Generating the .ITF File.......cccciiiiiir e 5

2.1. Generating the .ITF File by the NiceLabel Pro Software ............ccccccoovviiieeeeeininns 5

2.2. Generating the .ITF File by the BarTender Software ............cccccceveeiiiiiciiiieeeee s 7
3. Uploading the .ITF File to SAPSCIIPt .......cccccciiiieirccccecrrre e snee e e nnes 1
4. Printing Data from SAP System to SATO Printer........cccccoiivicccieerrennnssccsseeeeeeessssssnnes 24



Overview

This document is to show how to print the label from SAP system using SAPscript to SATO
printers.
The steps are:

Generating the .ITF file.
Uploading the ITF file to SAP system.
Sending the data from the SAP system to the SATO printer in order to print the label.

Note: We need to set the SATO printer to use Non-Standard code in SBPL Protocol (refer to each
printer operator manual for details on setting the Non-Standard Protocol). All the “/ ¢, “* “and “=
“characters must remain in the .ITF file when sending the data from SAP system.

However, the above mentioned characters must be removed when printing the .ITF locally (for
example from All-In-One Tool).
The SAPscript technology provides English characters printing so far.



Generating the .ITF 2
File

2.1. Generating the .ITF File by the NiceLabel Pro Software

Note: You can only use the NicelLabel Pro (V6) software for this procedure. The newer version of the
NicelLabel Pro does not support exporting .ITF file.
NiceLabel Pro (V6) edition has EOL and the end of support will be by 31 Dec 2018.

1. Create label template using NicelLabel Pro (V6).
Create keyboard prompt variable text.
Assign SATO Printer fonts for the variable text.
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Please make sure that the selected printer at this point is the same as the actual printer used to

print the data out from SAP system — you can select the printer by double clicking the form.



Select “Export” -> “Export to SAP” from the “File” menu.
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Enter SAP R/3 variable names that tally with the keyboard prompt variables and click the “OK”

button.
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Make sure that “SAP R/3 Variable Name” positions (for SAP system to pass these values, the
SAPscript’'s form must have some changes implemented in ABAP language) are filled in
accordingly.



6. The .ITF file will be generated and saved in the location as shown in the “Information” dialog box.
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C:hUzersh o cwhDocumentsiby LabelstLabels\ML-Label itf

Please upload the generated file to SAPYR 3 spstem using SAP Script.
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2.2. Generating the .ITF File by the BarTender Software

1. Set up Seagull SATO printer driver in order to generate the ITF file with Non-Standard Code and
define cache storage as printer's RAM.

a) In Printer Properties, select “Tools” -> “Manage Cache”.
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b) Select “Cache Settings” -> “Cache Storage” -> “RAM” and click the “OK” button.
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c) In Printer Properties, select “Tools” -> “Configure” -> “Printer Options” and clear the
“Standard Control Codes” checkbox. Then click the “OK” button.
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2. Create label template using BarTender software.

3. Create keyboard prompt variable text.



4.

Assign SATO Printer fonts for the variable text.
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Select “Export Printer Code Template” from the “File” menu.
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Select “SAP ITF (UTF-8)" -> Select “All in One File” -> Click Export.
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ITF file with variables is generated.
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ploading the .ITF
File to SAPscript

1. Type “SE71” in the box below.
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3. Save the newly generated Form.
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4. Enter an appropriate package in the “Package” textbox and save the changes.
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5. Click “Form” -> “Activate” to activate the Form.
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7. Fill in the attributes in “Standard Attributes” box at the bottom of the screen and click the save

icon. The PAGE1 has been created.

5 Fom  Edit Goto  Attrbutsg  Utibes(M) Settngs  System  Heb
° - {ae 0OOp A0 0m

Form: Change Pages: Y =2 _|U-%) SAPSCR

& B wndows Page Windows  Paragraph Formats  Character Formats (4]
Pages
Page Descrpton NextPzge Mode Ho.ype
PAGEL INC RRABIC
Page 1 of 1 e
Standard Attributes
Page [engE1 Peoratin: Fo ety
Hext page BRGE] Page Counter
Made INC
Bk Attt Hurrbering Type [AmaB1c |
T a
Resource fame | I Output length
Pint moda | [ lUpgercase

Jleiw ]

8. Go to “Page Windows” tab.

[ Fem Edit fGobo  Attrbutes  Utiies(M)

(/] -

Setbngs  System  Heb

«H @@ phap B0 o®

= & windows | Page Windows | Paragraph Formaks  (haracter Formats  [d

9. Select “Edit” -> “Create Element”.

[E Fom | Edit | Goto  Attrbutes  Utikes(M] Setbngs  Swstem  Heb

(] Create Elament...  ShitsFs oy 00050 am

Form:  Dekte Sement..  Shitsss | DAMIAN_SAPSCR

= ; - TJaxt Bermants Fa L Hen it T

Man Window

Page Wni  [zncel F12

Page [pases

‘Window Description Left Upger Width Hght
I 1
L

14



10. Accept the pop-up window
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11. The blue element has been created as the change is visible as shown. Fill in the “Standard
Attributes” and click the save icon.

& Fom Edt Goto  Attrbuy

9 | -

Setings  System  Hab
Dnap 58 eF
Form: Change Page Windows: Y_DAMIAN_SAPSCR

@ (3 (% S pages Wncows Paragraph Formats  Character Farmess (i)

Page Window

Page [ease1

Wndow Descripbion Left Upper Whdth Hoht
MAIH 00 Main Window 000CM 0,00 CM 0,000 0,000

Page Window 1 of 1

(=
=

Standard Attnbutas |
Window HAIH Descrption Main Windowr
Window type HAIN
Laft Margin 0 Too Wndow width 5 Jou]
4 -
Upper margin 0 o Windaw height Ld ]C!G!

D Filn &l required entry figkds

Bl 0] ]=]

15



12. Go to “Paragraph Format” tab.
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13. Fill in the “Standard Attributes” and click the save icon.
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15. Fill in the “Standard Attributes” accordingly and click the save icon.
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17. Click the “Basic Settings” button.
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18. Fill in the parameters accordingly and click the save icon.
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19. Click “Form” -> “Activate” to activate the Form.
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20. The “Status” box shows “Active — Saved”.
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21. Type “S0O10” in the box as shown.
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22. Type the Standard Text name in the “Text Name” box, set up the “Language” and click “Create”
button.
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23. Click “Text” -> “Upload” to upload your .ITF file created in the previous section of this document.
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theck
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24. Select “ITF” format.

[Z Jext Ect Goto Fomret  [nsent  System  Hep

-
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Fx Inset Lne Fortet Page T~ ok B 0 [
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25. Select the .ITF file that has been generated.
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26. Click the “Allow” button.

E Jaxt Edk Goto Format  Jnsert  System  Help
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27. The .ITF file is uploaded as shown.
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9 r«H Qe 2R DNOLITT7 W

Save [Crriss)

|mmwmv_nmnsr_mumm
| B mnset ine Fommt Page [T i B o D

/ ~RIVHIOIBHOCD
; B-coz

s | ~EL

4 ~AIVDOZ4LH1ZOL

. B2
i 1
B

r Ba
 Fres

/ %2

/ *B1147

/ *¥i0768
/ ~L0302

i ~P02

/ ~K35

/ ~KIB

=  Cvdgdfg
= %2

/| *B1148
|/ “WI0EST
3 ~BE03234
= >LMERM
- %2

J “H1060

i *¥D0460
/ *P02

/ ~RDBED, 029,029, 34534
i ~20

/ ~B06%0

/ ~¥00461

i *GH0Z401600000000000000C00000000000C:00000000000C-000000C000000000000000
e 00000000000C0000000000C00000AC0000CI0000A00000CILFOCICI00ICICINCICICOIAC >
= 00000300000CI0000A00000CI1 FECA00O00CI0IFII0I000CIC0O0A0A000CI0IO0A0CA00AE > w

SYSTEM Liwes '3 — 38 /187 ———r

Imported text was inserted at the cursor postion

Bl e /=]

22



28. Click “Format” -> “Change Form”.

[= Ted: Edit  Goto E;:*Fns‘ﬂ Insart  Systam  Halbp

] Omrater =i DHhopL 58 e
| Paragraph...
| Change Standari  Lr:... _TXT Language EN
g Inset Lne Fom Fage £
Charge Styla...
cevebennilo,. b, CEDGE Fomm. T e e T
- P.ﬂ Carert... j i

Paragraph on/off
£ ~RIVHI00B+00D

W ~C32

i ~§E1

i AAIVIOE4LH1Z0L

s

29. Now it’s the time to connect the form to the text. Select the Form you have just created.
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30. Click the save icon to save the changes.
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Printing Data from
SAP System to
SATO Printer

1. After saving the form to the text in SAPscript (step 30 of section 3), click the print icon to print.

[ Text Edt Gote Fommat  Jnset  System  Heb
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Save [Cri+5)
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2. Select the appropriate “Output Device” and select the “Print Immediately” checkbox. Select the

correct printer in order to print the label — the label is being produced at this stage.
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3. You must go to the “Spool Administration” in order to select a correct device type when working

with SAPscript technology before printing the data from the SAP system.
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3 Critical Takeaways
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4. The Device Type is shown as follows. Choose the full admin option and set the character set
(language).
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